Versions-Angaben der benötigten libs für platformio.ini optimieren

@clemens: Laut

scheint die neueste Version der HX711-Bibliothek 0.7.4 zu sein. Bei Probleme mit der Wägezelle – Hanimandl wird jedoch die Version 0.7.2 referenziert. Vielleicht sollte das auch angepasst werden, damit es nicht zu Missverstaendnissen kommt?

image

cc @aholzhammer

@clemens @Andreas
Bei mir sieht das testweise so aus:

HX711 @ ^0.7.4
U8g2 @ ^2.28.6
ESP32Servo

Damit werden jeweils die angegebene oder höhere Versionen genutzt.

1 Like

Danke Andreas / @aholzhammer, dann ändere ich das in der hani-mandl/platformio.ini at master · ClemensGruber/hani-mandl · GitHub auch und zwar mit

^
für

any compatible version (new functionality in a backwards compatible manner and patches are allowed, 1.x.x). RECOMMENDED

wird auch empfohlen, siehe: pio lib install — PlatformIO 5.0.5a1 documentation

^ ist etwas konservativer als > für >1.2.3 - any version greater than 1.2.3. >=, <, and <= are also possible

Done via Update platformio.ini · ClemensGruber/hani-mandl@fa2eb38 · GitHub

Hi Clemens, Hi Andreas,

ich hatte hier gestern auch noch zwei Patches vorbereitet. Add CI using PlatformIO by amotl · Pull Request #16 · ClemensGruber/hani-mandl · GitHub sollte aufzeigen, dass der Build fehlschlaegt und Update library versions by amotl · Pull Request #17 · ClemensGruber/hani-mandl · GitHub zieht ihn dann wieder gerade.

Die Notation ^0.7.4

koennten wir versuchen, wenn die Autoren der Bibliotheken die Versionierung ordentlich gestalten.

Viele Gruesse,
Andreas.